<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"/><meta name="classification" content="cars"/><meta name="doc-rights" content="Copywritten Work"/><title>2019 Mitsubishi L200 world premiere</title><meta name="title" content="2019 Mitsubishi L200 world premiere"/><meta name="description" content="2019 Mitsubishi L200 world premiere - The current generation Mitsubishi L200 was co-developed with Fiat and was introduced not so long ago. We are used seeing pick-up trucks staying"/><meta name="keywords" content="2019 Mitsubishi L200 world premiere, 2019, Mitsubishi, L200, world, premiere"/><meta name="robots" content="index, follow"/><link rel="canonical" href="http://www.carsession.com/car-news/2019-mitsubishi-l200-world-premiere.html"/><meta property="og:site_name" content="CarSession"><meta property="og:title" content="2019 Mitsubishi L200 world premiere"><meta property="og:url" content="http://www.carsession.com/car-news/2019-mitsubishi-l200-world-premiere.html"><meta property="og:type" content="article"><meta property="og:description" content="The current generation Mitsubishi L200 was co-developed with Fiat and was introduced not so long ago. We are used seeing pick-up trucks staying even 10 years on the market, but the L200 is ready to welcome its new heir."><meta property="og:image" content="http://www.carsession.com/news/photos/Mitsubishi/2019-Mitsubishi-L200-world-premiere.jpg"><base href="http://www.carsession.com/"/><link rel="shortcut icon" href="http://www.carsession.com/images/favicon.ico"/><link href="http://www.carsession.com/wfiles/A.styles.css.pagespeed.cf.-GQpq1nLK9.css" rel="stylesheet" type="text/css" media="screen"/><link rel="alternate" type="application/atom+xml" title="ATOM 1.0" href="http://www.carsession.com/rss/car-news.xml"/><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.carsession.com/rss/car-news-rss.xml"/></head><body><center><div class="bdy"><div class="bdy_cnt"><div class="header"><div class="logo" onclick="window.location.href = 'http://www.carsession.com'" title="Hot Car News, Custom Car Parts, Custom Car Photos, Auto Shows. Get updated with Hot Car News as they happen or get exposure for your ride on Car Session">&nbsp;</div><div class="topCnt"><div class="topMenu_cnt"><ul class="topMenu"><li><a href="http://www.carsession.com/car-news/" title="Car News">Car News</a></li><li><a href="http://www.carsession.com/car-specs/" title="Car Specs">Car Specs</a></li><li><a href="http://www.carsession.com/auto-shows/" title="Auto Shows">Auto Shows</a></li><li><a href="http://www.carsession.com/your-ride/" title="Your Ride">Your Ride</a></li></ul></div><div class="searchCnt"><script>(function(){var cx='partner-pub-6772297789150570:7415139696';var gcse=document.createElement('script');gcse.type='text/javascript';gcse.async=true;gcse.src=(document.location.protocol=='https:'?'https:':'http:')+'//www.google.com/cse/cse.js?cx='+cx;var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(gcse,s);})();</script><gcse:searchbox-only></gcse:searchbox-only></div></div></div><div class="content"><div class="moduletable_pathway"><a href="http://www.carsession.com/" title="Home">Home</a> &raquo; <a href="http://www.carsession.com/car-news/" title="News">News</a> &raquo; <a href="http://www.carsession.com/car-news/mitsubishi/" title="Mitsubishi">Mitsubishi</a> &raquo; 2019 Mitsubishi L200 world premiere</div><div class="contentCnt"><div class="left"><div class="page"><div class="art_title"><h1 title="2019 Mitsubishi L200 world premiere"><a href="http://www.carsession.com/car-news/2019-mitsubishi-l200-world-premiere.html" rel="bookmark">2019 Mitsubishi L200 world premiere</a></h1><p class="post-info">13 November 2018 17:46:10</p><table cellpadding="0" cellspacing="0" border="0" class="borderCollapse"><tr><td valign="top"><a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="carsession">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></td><td valign="top"><iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.carsession.com%2Fcar-news%2F2019-mitsubishi-l200-world-premiere.html&amp;layout=button_count&amp;show_faces=false&amp;width=450&amp;action=like&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:21px;" allowTransparency="true"></iframe></td></tr></table></div><div class="page_text"><div class="artBanner300"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6772297789150570" data-ad-slot="1126430499"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div><b>The current generation Mitsubishi L200 was co-developed with Fiat and was introduced not so long ago. We are used seeing pick-up trucks staying even 10 years on the market, but the L200 is ready to welcome its new heir.&nbsp;</b></div><div><br/></div><div>Mitsubishi announced the world premiere of the new Mitsubishi L200 one-ton pickup truck in Bangkok, and is to start sales in Thailand on November 17.</div><div><br/></div><div>The new Mitsubishi L200 is the latest version of a model which is celebrating its 40th birthday this year, and is produced at the Laem Chabang Plant operated by Mitsubishi Motors (Thailand), MMC&rsquo;s producer and distributor in Thailand.</div><div><br/></div><div><b>The vehicle is a global strategic model which, following its Thai launch, will be launched in the in other ASEAN markets as well as Oceania, the Middle East, Europe, Africa and Latin America. Eventually it will be sold in some 150 countries around the globe.</b></div><div class="articleMainImg"><div class="articleTopTools"><div class="articleTopTool1"></div><div class="articleTopTool2"><script type="text/javascript" src="http://w.sharethis.com/widget/?tabs=web%2Cpost%2Cemail&amp;charset=utf-8&amp;style=default&amp;publisher=b79192db-9a3c-4ea5-93bb-cbbf528b5f09&amp;headerbg=%23efefef&amp;inactivebg=%23dddddd"></script></div></div><div class="articleImgRight"><a href="http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere.html" title="2019 Mitsubishi L200 world premiere Photos"><img src="news/images/Mitsubishi/276x184x2019-Mitsubishi-L200-world-premiere.jpg.pagespeed.ic.p_39hwXV5Q.jpg" border="0" alt="2019 Mitsubishi L200 world premiere" title="2019 Mitsubishi L200 world premiere" width="276" height="184"/></a></div><div class="articleGalleryDiv"><a href="http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere.html" title="2019 Mitsubishi L200 world premiere Photos">2019 Mitsubishi L200 world premiere Photos</a></div></div><div><br/></div><div>The front of the vehicle incorporates the new-generation &ldquo;Dynamic Shield&rdquo; front design concept: The high engine hood line and beefier-looking lamps located higher up give the new model a more powerful and imposing front end. Newly sculpted body curves with contrasting sharp lines, extended wheel flares and bright accents add modernity to the truck. The lighting and bumpers become part of the tough design, framing the front and rear designs and adding visual width.</div><div><br/></div><div>New Mitsubishi L200 4WD models are fitted with either Super-Select 4WD, which delivers optimum traction and handling characteristics for any given surface, or Easy-Select 4WD, which simplifies switching between drive modes for different road surfaces. With the addition of new drive modes, both 4WD systems deliver improved off-road performance.</div><div><br/></div><div><b>Both Super-Select and Easy-Select 4WD systems use a new Off-road Mode which has GRAVEL, MUD/SNOW, SAND and ROCK (in 4LLc only) settings. When engaged, Off-road Mode integrally controls engine power, transmission and braking to regulate the amount of wheel slip and thereby maximize all-terrain performance and self-extraction performance in mud or snow. Hill Descent Control electronically controls the speed to allow the driver to negotiate steep or slippery descents more safely and with more assurance.</b></div><div><br/></div><div>Providing convenient driver assistance are the Multi Around Monitor, which generates a bird&rsquo;s eye view image of the area around the vehicle, and Parking Sensors.</div><div><br/></div><div><br/></div><p class="postmetadata">Tags: <a href="http://www.carsession.com/car-news/tag/mitsubishi/" rel="tag">mitsubishi</a>, <a href="http://www.carsession.com/car-news/tag/mitsubishi+l200/" rel="tag">mitsubishi l200</a>, <a href="http://www.carsession.com/car-news/tag/new+mitsubishi+l200/" rel="tag">new mitsubishi l200</a>, <a href="http://www.carsession.com/car-news/tag/2019+mitsubishi+l200/" rel="tag">2019 mitsubishi l200</a>, <a href="http://www.carsession.com/car-news/tag/new+l200/" rel="tag">new l200</a></p><p class="postmetadata">Posted in <a href="http://www.carsession.com/car-news/mitsubishi/" title="See all articles in Mitsubishi Latest News" rel="category tag" class="artNoBorder">Mitsubishi</a>, <a href="http://www.carsession.com/car-news/new-vehicles/" title="See all articles in New Vehicles" rel="category tag" class="artNoBorder">New Vehicles</a></p></div><div class="myarts_gallery"><div class="myarts_gallery_title"><a href="http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere.html" title="Photos 2019 Mitsubishi L200 world premiere">2019 Mitsubishi L200 world premiere Photos</a> <span class="myart_smalltext">(3 photos)</span></div><div class="myarts_galleryItems"><ul><li><a href="news/photos/Mitsubishi/2019-Mitsubishi-L200-world-premiere.jpg" target="_blank" onclick="window.location='http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere-0.jpg.html';return false;" title="2019 Mitsubishi L200 world premiere"><img src="news/photos/Mitsubishi/xth-2019-Mitsubishi-L200-world-premiere.jpg.pagespeed.ic.eviAnedNGJ.jpg" border="0" title="2019 Mitsubishi L200 world premiere" alt="2019 Mitsubishi L200 world premiere"/></a></li><li><a href="news/photos/Mitsubishi/2019-Mitsubishi-L200-world-premiere-794250237.jpg" target="_blank" onclick="window.location='http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere-1.jpg.html';return false;" title="2019 Mitsubishi L200 world premiere"><img src="news/photos/Mitsubishi/xth-2019-Mitsubishi-L200-world-premiere-794250237.jpg.pagespeed.ic.bPfZ-rOo8l.jpg" border="0" title="2019 Mitsubishi L200 world premiere" alt="2019 Mitsubishi L200 world premiere"/></a></li><li><a href="news/photos/Mitsubishi/2019-Mitsubishi-L200-world-premiere-197253954.jpg" target="_blank" onclick="window.location='http://www.carsession.com/photos/mitsubishi/2019-mitsubishi-l200-world-premiere-2.jpg.html';return false;" title="2019 Mitsubishi L200 world premiere"><img src="news/photos/Mitsubishi/th-2019-Mitsubishi-L200-world-premiere-197253954.jpg" border="0" title="2019 Mitsubishi L200 world premiere" alt="2019 Mitsubishi L200 world premiere"/></a></li></ul></div></div><div class="page_subTitle"><h3>Related Articles</h3></div><div class="myarts_relatedList"><ul><li><a href="http://www.carsession.com/car-news/mitsubishi-l200-new-model-to-be-launched-in-november.html" title="Mitsubishi L200 new model to be launched in November" rel="bookmark">Mitsubishi L200 new model to be launched in November </a></li><li><a href="http://www.carsession.com/car-news/mitsubishi-outlander-phev-reach-record-sales-in-september.html" title="Mitsubishi Outlander PHEV reach record sales in September" rel="bookmark">Mitsubishi Outlander PHEV reach record sales in September </a></li><li><a href="http://www.carsession.com/car-news/mitsubishi-asx-juno-trim-level-introduced.html" title="Mitsubishi ASX Juno trim level introduced" rel="bookmark">Mitsubishi ASX Juno trim level introduced </a></li><li><a href="http://www.carsession.com/car-news/2019-mitsubishi-outlander-petrol-available-in-uk.html" title="2019 Mitsubishi Outlander petrol available in UK" rel="bookmark">2019 Mitsubishi Outlander petrol available in UK </a></li><li><a href="http://www.carsession.com/car-news/2019-mitsubishi-outlander-phev-uk-prices-revealed.html" title="2019 Mitsubishi Outlander PHEV UK prices revealed" rel="bookmark">2019 Mitsubishi Outlander PHEV UK prices revealed </a></li><li><a href="http://www.carsession.com/car-news/mitsubishi-outlander-phev-remains-best-sold-hybrid-in-uk.html" title="Mitsubishi Outlander PHEV remains best sold hybrid in UK" rel="bookmark">Mitsubishi Outlander PHEV remains best sold hybrid in UK </a></li><li><a href="http://www.carsession.com/car-news/new-mitsubishi-shogun-launched-in-uk.html" title="New Mitsubishi Shogun launched in UK" rel="bookmark">New Mitsubishi Shogun launched in UK </a></li><li><a href="http://www.carsession.com/car-news/2019-mitsubishi-outlander-phev-updates-detailed.html" title="2019 Mitsubishi Outlander PHEV updates detailed" rel="bookmark">2019 Mitsubishi Outlander PHEV updates detailed </a></li><li><a href="http://www.carsession.com/car-news/mitsubishi-l200-barbarian-svp-ii-launched-in-uk.html" title="Mitsubishi L200 Barbarian SVP II launched in UK" rel="bookmark">Mitsubishi L200 Barbarian SVP II launched in UK </a></li><li><a href="http://www.carsession.com/car-news/mitsubishi-eclipse-cross-arrives-in-the-us.html" title="Mitsubishi Eclipse Cross arrives in the US" rel="bookmark">Mitsubishi Eclipse Cross arrives in the US </a></li></ul></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:600px;height:300px" data-ad-client="ca-pub-6772297789150570" data-ad-slot="3765816095"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><div class="artComms"></div><div class="page_subTitle"><h3>Leave a Comment</h3></div><div class="page_text"><a name="respond"></a><form action="index.php" method="post" name="commForm"><table cellpadding="4" cellspacing="0" border="0" class="borderCollapse"><tr><td colspan="2">Fields marked with * are required</td></tr><tr><td valign="top">Name <sup class="required">*</sup>:</td><td valign="top"><input type="text" name="name" size="30" class="inputbox" value=""/></td></tr><tr><td valign="top">Email <sup class="required">*</sup>:</td><td valign="top"><input type="text" name="email" size="30" class="inputbox" value=""/></td></tr><tr><td valign="top">Comment <sup class="required">*</sup>:</td><td valign="top"><textarea name="text" rows="7" cols="40" class="inputbox"></textarea></td></tr><tr><td valign="middle">Code <sup class="required">*</sup>:</td><td valign="top"><table cellpadding="0" cellspacing="0" border="0" class="borderCollapse"><tr><td valign="middle"><input type="text" name="je112223668a33894ffebee547521b048" size="20" class="inputbox"></td><td valign="middle" class="captchaTD">&nbsp;&nbsp;<img src="/components/classes/captcha.php" alt="CAPTCHA" id="captcha" width="60" height="18"/></td></tr></table></td></tr><tr><td colspan="2"><center><input type="button" name="send" value="Post" class="button" onclick="validate()"/></center></td></tr></table><input type="hidden" name="jee01cccef3e042a572baf2e9b0ca27da" value="1"/><input type="hidden" name="option" value="com_my_articles"/><input type="hidden" name="task" value="save_comment"/><input type="hidden" name="aid" value="14050"/></form></div></div></div><div class="moduletable_icons"><ul class="iconList"><li><a href="http://www.carsession.com/contact/" title="Contact CarSession"><img src="/images/49x50xemail_icon.gif.pagespeed.ic.egeqO7YyF2.png" border="0" alt="Email" title="Email" width="49" height="50"/></a></li><li><a href="https://www.youtube.com/user/CarSession" title="CarSession on YouTube" target="_blank"><img src="/images/49x50xyoutube_icon.gif.pagespeed.ic.X_xTPkBSxI.png" border="0" alt="YouTube" title="YouTube" width="49" height="50"/></a></li><li><a href="http://feeds2.feedburner.com/CarSession" title="RSS" rel="alternate" type="application/rss+xml" target="_blank"><img src="/images/49x50xrss_icon.gif.pagespeed.ic.PCwixrex_a.png" border="0" alt="RSS" title="RSS" width="49" height="50"/></a></li><li><a href="http://twitter.com/carsession" title="CarSession on Twitter" target="_blank"><img src="/images/49x50xtwitter_icon.gif.pagespeed.ic.cRnDOR6y_C.png" border="0" alt="Twitter" title="Twitter" width="49" height="50"/></a></li><li><a href="http://www.facebook.com/pages/CarSessioncom-Car-News/188926191646" title="CarSession on Facebook" target="_blank"><img src="/images/49x50xfacebook_icon.gif.pagespeed.ic.-KN8b_dmf0.png" border="0" alt="facebook" title="facebook" width="49" height="50"/></a></li><li><a href="http://feedburner.google.com/fb/a/mailverify?uri=CarSession&amp;loc=en_US" title="Newsletter"><img src="/images/49x50xfeedburner_icon.gif.pagespeed.ic.2Mo24Gim-4.png" border="0" alt="feedburner" title="feedburner" width="49" height="50"/></a></li></ul></div><div class="right"><div class="moduletable_latest"><h4>Latest Car News</h4><ol class="mReadList"><li><a href="http://www.carsession.com/car-news/2019-hyundai-veloster-n-us-pricing-announced.html" title="2019 Hyundai Veloster N US pricing announced" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/hyundai/97x64x2019-hyundai-veloster-n-us-pricing-announced-1.jpg.pagespeed.ic.R4XiBdlGKo.jpg" border="0" title="2019 Hyundai Veloster N US pricing announced" alt="2019 Hyundai Veloster N US pricing announced" width="97" height="64"/></a><h3><a href="http://www.carsession.com/car-news/2019-hyundai-veloster-n-us-pricing-announced.html" rel="bookmark" title="2019 Hyundai Veloster N US pricing announced">2019 Hyundai Veloster N US pricing announced </a></h3></li><li><a href="http://www.carsession.com/car-news/mercedes-a-class-gets-two-new-diesel-engines-in-the-uk.html" title="Mercedes A-Class gets two new diesel engines in the UK" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/mercedes/97x64xmercedes-a-class-gets-two-new-diesel-engines-in-the-uk-1.jpg.pagespeed.ic.JELAI1pZhS.jpg" border="0" title="Mercedes A-Class gets two new diesel engines in the UK" alt="Mercedes A-Class gets two new diesel engines in the UK" width="97" height="64"/></a><h3><a href="http://www.carsession.com/car-news/mercedes-a-class-gets-two-new-diesel-engines-in-the-uk.html" rel="bookmark" title="Mercedes A-Class gets two new diesel engines in the UK">Mercedes A-Class gets two new diesel engines in the UK </a></h3></li><li><a href="http://www.carsession.com/car-news/jaguar-f-type-rally-cars-celebrate-70-years-of-sport-heritage.html" title="Jaguar F-Type rally cars celebrate 70 years of sport heritage" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/jaguar/97x64xjaguar-f-type-rally-cars-celebrate-70-years-of-sport-heritage-1.jpg.pagespeed.ic.jZL4avNBEp.jpg" border="0" title="Jaguar F-Type rally cars celebrate 70 years of sport heritage" alt="Jaguar F-Type rally cars celebrate 70 years of sport heritage" width="97" height="64"/></a><h3><a href="http://www.carsession.com/car-news/jaguar-f-type-rally-cars-celebrate-70-years-of-sport-heritage.html" rel="bookmark" title="Jaguar F-Type rally cars celebrate 70 years of sport heritage">Jaguar F-Type rally cars celebrate 70 years of sport heritage </a></h3></li><li class="listSeparator">&nbsp;</li><li><a href="http://www.carsession.com/car-news/seat-1400-celebrates-65-years-since-launch.html" title="Seat 1400 celebrates 65 years since launch" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/seat/97x65xseat-1400-celebrates-65-years-since-launch-1.jpg.pagespeed.ic.VdRswkVxv6.jpg" border="0" title="Seat 1400 celebrates 65 years since launch" alt="Seat 1400 celebrates 65 years since launch" width="97" height="65"/></a><h3><a href="http://www.carsession.com/car-news/seat-1400-celebrates-65-years-since-launch.html" rel="bookmark" title="Seat 1400 celebrates 65 years since launch">Seat 1400 celebrates 65 years since launch </a></h3></li><li><a href="http://www.carsession.com/car-news/2019-mitsubishi-l200-world-premiere.html" title="2019 Mitsubishi L200 world premiere" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/mitsubishi/97x64x2019-mitsubishi-l200-world-premiere-1.jpg.pagespeed.ic.raTO2pYG5J.jpg" border="0" title="2019 Mitsubishi L200 world premiere" alt="2019 Mitsubishi L200 world premiere" width="97" height="64"/></a><h3><a href="http://www.carsession.com/car-news/2019-mitsubishi-l200-world-premiere.html" rel="bookmark" title="2019 Mitsubishi L200 world premiere">2019 Mitsubishi L200 world premiere </a></h3></li><li><a href="http://www.carsession.com/car-news/bmw-m340i-xdrive-has-382-horsepower-and-will-be-unveiled-in-la.html" title="BMW M340i xDrive has 382 horsepower and will be unveiled in LA" rel="bookmark"><img src="http://www.carsession.com/car-news/small-images/bmw/97x65xbmw-m340i-xdrive-has-382-horsepower-and-will-be-unveiled-in-la-1.jpg.pagespeed.ic.8DQtoyQkZG.jpg" border="0" title="BMW M340i xDrive has 382 horsepower and will be unveiled in LA" alt="BMW M340i xDrive has 382 horsepower and will be unveiled in LA" width="97" height="65"/></a><h3><a href="http://www.carsession.com/car-news/bmw-m340i-xdrive-has-382-horsepower-and-will-be-unveiled-in-la.html" rel="bookmark" title="BMW M340i xDrive has 382 horsepower and will be unveiled in LA">BMW M340i xDrive has 382 horsepower and will be unveiled in LA </a></h3></li></ol></div><div class="right_split"><div class="right_left"><div class="skyScrapper"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:160px;height:600px" data-ad-client="ca-pub-6772297789150570" data-ad-slot="8789298092"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="right_right"><div class="moduletable_relspecs"><h3>Related Specs</h3><ol class="modrs"><li><h4><a href="http://www.carsession.com/car-specs/2003-mitsubishi-cz2-cabriolet-concept.html" title="2003 Mitsubishi CZ2 Cabriolet Concept">2003 Mitsubishi CZ2 Cabriolet Concept </a></h4>Engine: Inline-4N/AN/A</li><li><h4><a href="http://www.carsession.com/car-specs/2002-mitsubishi-lancer-evoution-vii-wrc2.html" title="2002 Mitsubishi Lancer Evoution VII WRC2">2002 Mitsubishi Lancer Evoution VII WRC2 </a></h4>Engine: 4G63 Inline-4,&nbsp;Power: 223.7 kw / 300.0 bhp @ 300.0 rpm,&nbsp;Torque: 540 nm / 398.3 ft lbs @ 3500 rpm</li><li><h4><a href="http://www.carsession.com/car-specs/2001-mitsubishi-cz2-concept.html" title="2001 Mitsubishi CZ2 Concept">2001 Mitsubishi CZ2 Concept </a></h4>Engine: GDI Inline-4N/AN/A</li><li><h4><a href="http://www.carsession.com/car-specs/2004-mitsubishi-eclipse-concept_e.html" title="2004 Mitsubishi Eclipse Concept-E">2004 Mitsubishi Eclipse Concept-E </a></h4>Engine: Hybrid MIVEC V6 & Electric Motor,&nbsp;Power: 200 kw / 268.2 bhpN/A</li><li><h4><a href="http://www.carsession.com/car-specs/2006-mitsubishi-eclipse-gt.html" title="2006 Mitsubishi Eclipse GT">2006 Mitsubishi Eclipse GT </a></h4>Engine: Cast Iron V6,&nbsp;Power: 193.9 kw / 260 bhp @ 5750 rpm,&nbsp;Torque: 352.51 nm / 260 ft lbs @ 4500 rpm</li></ol></div></div></div><div class="facebookbox"><div class="fb-like-box" data-href="http://www.facebook.com/carsession" data-width="350" data-height="250" data-show-faces="true" data-stream="false" data-header="false"></div></div><div class="moduletable_subcats"><div id="accordion"><h3><a href="http://www.carsession.com/car-news/new-vehicles/" title="Car News New Vehicles" rel="category tag" class="headActive">New Vehicles</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/hyundai-i30-n-line-starts-at-£21255-in-uk.html" title="Hyundai i30 N Line starts at £21,255 in UK" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/hyundai/hyundai-i30-n-line-starts-at-£21-255-in-uk-1.jpg" title="Hyundai i30 N Line starts at £21,255 in UK" alt="Hyundai i30 N Line starts at £21,255 in UK" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/hyundai-i30-n-line-starts-at-£21255-in-uk.html" title="Hyundai i30 N Line starts at £21,255 in UK" rel="bookmark">Hyundai i30 N Line starts at £21,255 in UK </a><br>After a long wait, Hyundai is finally making the most of its new N Performance division. The South-Korean manufacturer has officially announced the pricing  ... </span></div><h3><a href="http://www.carsession.com/car-news/concept-cars/" title="Car News Concept Cars" rel="category tag">Concept Cars</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/subaru-viziv-tourer-concept-unveiled-in-geneva.html" title="Subaru Viziv Tourer Concept unveiled in Geneva" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/subaru/xsubaru-viziv-tourer-concept-unveiled-in-geneva-1.jpg.pagespeed.ic.inBMasuLPf.jpg" title="Subaru Viziv Tourer Concept unveiled in Geneva" alt="Subaru Viziv Tourer Concept unveiled in Geneva" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/subaru-viziv-tourer-concept-unveiled-in-geneva.html" title="Subaru Viziv Tourer Concept unveiled in Geneva" rel="bookmark">Subaru Viziv Tourer Concept unveiled in Geneva </a><br>Even if it's not recording huge volumes in Europe, Subaru didn't want to miss this year Geneva Motor Show. So it kept the stand and unveiled the Subaru  ... </span></div><h3><a href="http://www.carsession.com/car-news/custom-cars/" title="Car News Custom Cars" rel="category tag">Custom Cars</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/hennessey-launched-heritage-f-150-with-758-hp.html" title="Hennessey launched Heritage F-150 with 758 HP" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/ford/xhennessey-launched-heritage-f-150-with-758-hp-1.jpg.pagespeed.ic.5RG3Vojd02.jpg" title="Hennessey launched Heritage F-150 with 758 HP" alt="Hennessey launched Heritage F-150 with 758 HP" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/hennessey-launched-heritage-f-150-with-758-hp.html" title="Hennessey launched Heritage F-150 with 758 HP" rel="bookmark">Hennessey launched Heritage F-150 with 758 HP </a><br>Hennessey has launched another Heritage model for its 19th anniversary. The car is a F-150 pick-up truck which got a lovely Ford GT40 livery. To be more  ... </span></div><h3><a href="http://www.carsession.com/car-news/future-cars/" title="Car News Future Cars" rel="category tag">Future Cars</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/peugeot-to-develop-new-range-of-sporty-hybrids.html" title="Peugeot to develop new range of sporty hybrids" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/peugeot/xpeugeot-to-develop-new-range-of-sporty-hybrids-1.jpg.pagespeed.ic.a8im1QeLjG.jpg" title="Peugeot to develop new range of sporty hybrids" alt="Peugeot to develop new range of sporty hybrids" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/peugeot-to-develop-new-range-of-sporty-hybrids.html" title="Peugeot to develop new range of sporty hybrids" rel="bookmark">Peugeot to develop new range of sporty hybrids </a><br>Peugeot is doing its best to offers clients cleaner cars, but with the same level of performance. After presenting its new generation of PLUG-IN HYBRID  ... </span></div><h3><a href="http://www.carsession.com/car-news/market-news/" title="Car News Market News" rel="category tag">Market News</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/nissan-crossover-and-suv-sales-reached-record-numbers-in-2017.html" title="Nissan crossover and SUV sales reached record numbers in 2017" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/nissan/xnissan-crossover-and-suv-sales-reached-record-numbers-in-2017-1.jpg.pagespeed.ic.666VcwSJLh.jpg" title="Nissan crossover and SUV sales reached record numbers in 2017" alt="Nissan crossover and SUV sales reached record numbers in 2017" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/nissan-crossover-and-suv-sales-reached-record-numbers-in-2017.html" title="Nissan crossover and SUV sales reached record numbers in 2017" rel="bookmark">Nissan crossover and SUV sales reached record numbers in 2017 </a><br>Nissan had a great year in 2017, with sales reaching new records. Part fo this success is due to one of the best strategies when it comes to SUV segment. ... </span></div><h3><a href="http://www.carsession.com/car-news/gadgets/" title="Car News Gadgets" rel="category tag">Gadgets</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/volkswagen-details-its-future-lighting-technology.html" title="Volkswagen details its future lighting technology" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/volkswagen/xvolkswagen-details-its-future-lighting-technology-1.jpg.pagespeed.ic.fPxBzlD78W.jpg" title="Volkswagen details its future lighting technology" alt="Volkswagen details its future lighting technology" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/volkswagen-details-its-future-lighting-technology.html" title="Volkswagen details its future lighting technology" rel="bookmark">Volkswagen details its future lighting technology </a><br>Lighting technology is improving year by year and now is helping current cars to be safer. At an international workshop, Volkswagen is now showcasing  ... </span></div><h3><a href="http://www.carsession.com/car-news/various-news/" title="Car News Various News" rel="category tag">Various News</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/the-all-new-and-electric-mercedes-benz-eqc-to-enter-production-in-mid-2019.html" title="The all-new and electric Mercedes-Benz EQC to enter production in mid-2019" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/mercedes/xthe-all-new-and-electric-mercedes-benz-eqc-to-enter-production-in-mid-2019-1.jpg.pagespeed.ic.9YVS_QUd7M.jpg" title="The all-new and electric Mercedes-Benz EQC to enter production in mid-2019" alt="The all-new and electric Mercedes-Benz EQC to enter production in mid-2019" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/the-all-new-and-electric-mercedes-benz-eqc-to-enter-production-in-mid-2019.html" title="The all-new and electric Mercedes-Benz EQC to enter production in mid-2019" rel="bookmark">The all-new and electric Mercedes-Benz EQC to enter production in mid-2019 </a><br>A few months ago, Mercedes-Benz unveiled its first 100% electric car under the EQ brand. Its name is EQC and it is an SUV. Now, according to the German  ... </span></div><h3><a href="http://www.carsession.com/car-news/motorsports/" title="Car News Motorsports" rel="category tag">Motorsports</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/rally-driver-esapekka-lappi-joins-sebastien-ogier-at-citroen.html" title="Rally driver Esapekka Lappi joins Sebastien Ogier at Citroen" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/citroen/xrally-driver-esapekka-lappi-joins-sebastien-ogier-at-citroen-1.jpg.pagespeed.ic.J9Ig46_7Jv.jpg" title="Rally driver Esapekka Lappi joins Sebastien Ogier at Citroen" alt="Rally driver Esapekka Lappi joins Sebastien Ogier at Citroen" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/rally-driver-esapekka-lappi-joins-sebastien-ogier-at-citroen.html" title="Rally driver Esapekka Lappi joins Sebastien Ogier at Citroen" rel="bookmark">Rally driver Esapekka Lappi joins Sebastien Ogier at Citroen </a><br>Big movement on the WRC transfer market as the current season is about to finish. A few weeks ago we have announced you that Sebastien Ogier won't compete  ... </span></div><h3><a href="http://www.carsession.com/car-news/videos/" title="Car News Videos" rel="category tag">Videos</a></h3><div class="modArtCat_art_cnt"><a href="http://www.carsession.com/car-news/audi-is-teasing-a-sports-car-prior-to-paris-reaveal.html" title="Audi is teasing a sports car prior to Paris reaveal" rel="bookmark" class="modArtCatImg"><img src="http://www.carsession.com/car-news/swide-images2/audi/xaudi-is-teasing-a-sports-car-prior-to-paris-reaveal-1.jpg.pagespeed.ic._PM0qLpoud.jpg" title="Audi is teasing a sports car prior to Paris reaveal" alt="Audi is teasing a sports car prior to Paris reaveal" border="0"/></a><span class="modArtCat_art"><a href="http://www.carsession.com/car-news/audi-is-teasing-a-sports-car-prior-to-paris-reaveal.html" title="Audi is teasing a sports car prior to Paris reaveal" rel="bookmark">Audi is teasing a sports car prior to Paris reaveal </a><br>Audi has published a teaser video with a sports car that will be showcased during the 2018 Paris Motor Show. The teaser video was launched on the Audi  ... </span></div></div></div></div></div></div><div class="footer"><div class="copyright">Copyright <a href="/"><span class="copy_car">Car</span><span class="copy_session">Session</span><span class="copy_com">.com</span></a></div><div class="footer_menu"><ul class="footerMenu"><li><a href="http://www.carsession.com/car-news/" title="Car News">Car News</a></li><li><a href="http://www.carsession.com/car-specs/" title="Car Specs">Car Specs</a></li><li><a href="http://www.carsession.com/your-ride/" title="Your Ride">Your Ride</a></li><li><a href="http://www.carsession.com/rss/" rel="nofollow" title="RSS">RSS</a></li><li><a href="http://www.carsession.com/terms-of-service.html" rel="nofollow" title="Terms of Service">Terms of Service</a></li><li><a href="http://www.carsession.com/privacy-policy.html" rel="nofollow" title="Privacy Policy">Privacy Policy</a></li><li><a href="http://www.carsession.com/contact/" title="Contact">Contact</a></li><li><a href="http://www.carsession.com/sitemap/" title="Site Map">Site Map</a></li></ul></div></div></div></div></center><div id="fb-root"></div><script type="text/javascript">//<![CDATA[
(function(){function getScript(url,success){var script=document.createElement('script');script.src=url;var head=document.getElementsByTagName('head')[0],done=false;script.onload=script.onreadystatechange=function(){if(!done&&(!this.readyState||this.readyState=='loaded'||this.readyState=='complete')){done=true;success();script.onload=script.onreadystatechange=null;head.removeChild(script);}};head.appendChild(script);}getScript('http://www.carsession.com/wfiles/scripts.js',function(){$(document).ready(function(){doCatsAcordion()});window.fbAsyncInit=function(){FB.init({appId:'',status:true,cookie:true,xfbml:true});};(function(){var e=document.createElement('script');e.src=document.location.protocol+'//connect.facebook.net/en_US/all.js';e.async=true;document.getElementById('fb-root').appendChild(e);}());});})();
//]]></script><script type="text/javascript">var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-8027268-4']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=true;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'.google-analytics.com/ga.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s);})();</script></body></html>